blob: 22093bb1e8a2698ae75ea89315a8d656da64f755 [file] [log] [blame]
From 264cd761cc03e2dd85e57a1162db73c4beec0d07 Mon Sep 17 00:00:00 2001
From: Qian Hu <Qian.Hu@mediatek.com>
Date: Tue, 24 Sep 2019 11:33:56 +0800
Subject: [PATCH 4/8] [PATCH 4/9] weston: do not check master fd for DRM driver
give access to other module to use drm.
Signed-off-by: Qian Hu <Qian.Hu@mediatek.com>
---
libweston/launcher-direct.c | 5 -----
1 file changed, 5 deletions(-)
diff --git a/libweston/launcher-direct.c b/libweston/launcher-direct.c
index e0ce6d6..fe76f51 100644
--- a/libweston/launcher-direct.c
+++ b/libweston/launcher-direct.c
@@ -231,11 +231,6 @@ launcher_direct_open(struct weston_launcher *launcher_base, const char *path, in
if (major(s.st_rdev) == DRM_MAJOR) {
launcher->drm_fd = fd;
- if (!is_drm_master(fd)) {
- weston_log("drm fd not master\n");
- close(fd);
- return -1;
- }
}
return fd;
--
2.6.4