| #!/usr/bin/make -f |
| # -*- makefile -*- |
| # |
| # output every command that modifies files on the build system. |
| # export DH_VERBOSE = 1 |
| PACKAGENAME=tf-a |
| DESTDIR=$(shell pwd)/debian/$(PACKAGENAME) |
| |
| CFLAGS=\ |
| -Wno-error=missing-braces \ |
| -Wno-error=unused-function \ |
| -Wno-error=unused-variable \ |
| -Wno-error=maybe-uninitialized |
| |
| %: |
| dh $@ |
| |
| override_dh_auto_build: |
| make -j$(shell nproc) \ |
| CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)- \ |
| PLAT=mt8516 \ |
| CFLAGS="$(CFLAGS)" \ |
| LDFLAGS= \ |
| BL32=/usr/share/optee-os/tee.bin \ |
| BL33=/usr/share/u-boot/u-boot.bin \ |
| NEED_BL32=yes \ |
| NEED_BL33=yes \ |
| SPD=opteed \ |
| bl31 fiptool |
| |
| |
| override_dh_auto_install: |
| install -d $(DESTDIR)/usr/bin |
| install -d $(DESTDIR)/usr/share/tf-a |
| install -p -m 755 ./tools/fiptool/fiptool $(DESTDIR)/usr/bin/fiptool |
| install -p -m 755 ./build/mt8516/release/bl31.bin $(DESTDIR)/usr/share/tf-a/bl31.bin |
| |
| override_dh_installinit: |
| override_dh_strip: |
| true |