blob: efcd3d13f123d1798d87fcfd217084a74dfabc86 [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
# Uncomment this to turn on verbose mode.
export DH_VERBOSE = 1
VERSION := 4.4.22-aiy
ARCH := arm64
KERNEL_OPTIONS := \
ARCH=arm64 \
CROSS_COMPILDE=aarch64-linux-gnu- \
LOCALVERSION=-aiy
LDFLAGS :=
BUILD_DIR := $(CURDIR)/debian/build
DESTDIR := $(CURDIR)/debian/linux-image-$(VERSION)
DESTDIR_HEADERS := $(CURDIR)/debian/linux-headers-$(VERSION)
DESTDIR_KBUILD := $(CURDIR)/debian/linux-kbuild-$(VERSION)
%:
dh $@
override_dh_auto_clean:
true
override_dh_auto_build:
+make $(KERNEL_OPTIONS) defconfig
cat debian/defconfig | tee -a .config
+make $(KERNEL_OPTIONS) olddefconfig
+make $(KERNEL_OPTIONS) -j$(shell nproc) Image modules dtbs
override_dh_auto_install:
echo "Built kernel!"