blob: 3a65e279c57904ecd438f3d5ca89496521cb16f8 [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
# Uncomment this to turn on verbose mode.
export DH_VERBOSE = 1
VERSION := 4.4.22-aiy
ARCH := arm64
KERNEL_OPTIONS := \
ARCH=arm64 \
CROSS_COMPILE=aarch64-linux-gnu- \
LOCALVERSION=-aiy
LDFLAGS :=
BUILD_DIR := $(CURDIR)/debian/build
DESTDIR := $(CURDIR)/debian/linux-image-$(VERSION)
DESTDIR_HEADERS := $(CURDIR)/debian/linux-headers-$(VERSION)
DESTDIR_KBUILD := $(CURDIR)/debian/linux-kbuild-$(VERSION)
%:
dh $@
override_dh_auto_clean:
true
override_dh_auto_build:
+make ${KERNEL_OPTIONS} mt8167s_excelsior_defconfig
+make ${KERNEL_OPTIONS} -j$(shell nproc) Image modules dtbs
override_dh_auto_install:
echo "Built kernel!"