blob: f55a40a064d4340ba28d5ded7fb25464c1637490 [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
#
# output every command that modifies files on the build system.
# export DH_VERBOSE = 1
PACKAGENAME=excelsior-bootloader
DESTDIR=$(shell pwd)/debian/$(PACKAGENAME)
DRAM_SIZE := 2G
%:
dh $@ --with=systemd
override_dh_auto_build:
/usr/bin/fiptool create --soc-fw /usr/share/tf-a/bl31.bin --tos-fw /usr/share/optee-os/tee.bin --nt-fw /usr/share/u-boot/u-boot.bin fip.bin
./ubootenv.py -i /usr/share/u-boot/u-boot-initial-env -s 4096 -o u-boot-env.bin
/usr/bin/mkimage -A arm -T script -O linux -d boot.txt boot.scr
override_dh_auto_install:
install -d $(DESTDIR)/boot
install -p -m 755 ./fip.bin $(DESTDIR)/boot/fip.bin
install -p -m 755 ./u-boot-env.bin $(DESTDIR)/boot/u-boot-env.bin
install -p -m 755 ./boot.scr $(DESTDIR)/boot/boot.scr
install -p -m 644 ./overlays.txt $(DESTDIR)/boot/overlays.txt
install -p -m 755 ./mt8167-coral/bl2_1G.img $(DESTDIR)/boot/bl2_1G.img
install -p -m 755 ./mt8167-coral/bl2_2G.img ${DESTDIR}/boot/bl2_2G.img
@echo "Use ${DRAM_SIZE} memory config"
ln -sf bl2_${DRAM_SIZE}.img ${DESTDIR}/boot/bl2.img
override_dh_installinit:
override_dh_strip:
true