blob: 187cf7ae2f3164352352487d688401e7cdcf6c7b [file] [log] [blame]
#!/usr/bin/make -f
include /usr/share/dpkg/pkg-info.mk
PLUGINSDIR := $(shell pkg-config --variable=pluginsdir gstreamer-1.0)
PY_DESTDIR := debian/python3-edgetpuvision/$(PLUGINSDIR)/python
SO_DESTDIR := debian/gstreamer1.0-plugins-coral/$(PLUGINSDIR)
SO_SRCS := plugins/gstglbox.c plugins/gstcoral.c
SO_DEST := $(SO_DESTDIR)/libgstcoral.so
SO_DEPS := gstreamer-plugins-base-1.0 gstreamer-video-1.0 gstreamer-gl-1.0
export PYBUILD_NAME=edgetpuvision
%:
dh $@ --with python3 --buildsystem=pybuild
override_dh_install:
dh_install
install -d $(PY_DESTDIR)
install -g 0 -o 0 plugins/python/*.py $(PY_DESTDIR)
install -d $(SO_DESTDIR)
$(DEB_HOST_GNU_TYPE)-gcc `$(DEB_HOST_GNU_TYPE)-pkg-config --libs --cflags $(SO_DEPS)` $(CFLAGS) -shared -o $(SO_DEST) -DCORAL_VERSION=$(DEB_VERSION) $(SO_SRCS)