| From aa73bf5039dfd2cf0a52dd6fd22501d955cc1a00 Mon Sep 17 00:00:00 2001 |
| From: Tommy <mesilliac@gmail.com> |
| Date: Thu, 10 Jan 2013 09:18:43 +0100 |
| Subject: [PATCH] work around Logitech diNovo Edge keyboard firmware issue |
| |
| https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/269851 |
| --- |
| tools/hid2hci.rules | 5 ++++- |
| 1 files changed, 4 insertions(+), 1 deletions(-) |
| |
| diff --git a/tools/hid2hci.rules b/tools/hid2hci.rules |
| index db6bb03..7db4572 100644 |
| --- a/tools/hid2hci.rules |
| +++ b/tools/hid2hci.rules |
| @@ -11,7 +11,10 @@ ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", ATTR{bInterfaceProt |
| RUN+="hid2hci --method=dell --devpath=%p", ENV{HID2HCI_SWITCH}="1" |
| |
| # Logitech devices |
| -KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \ |
| +KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[3bc]", \ |
| + RUN+="hid2hci --method=logitech-hid --devpath=%p" |
| +# Logitech, Inc. diNovo Edge Keyboard |
| +KERNEL=="hidraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c714", \ |
| RUN+="hid2hci --method=logitech-hid --devpath=%p" |
| |
| ENV{DEVTYPE}!="usb_device", GOTO="hid2hci_end" |
| -- |
| 1.8.0.1 |
| |