blob: 1a241ee4f089d805bdf18f0780acc309ddf47fa5 [file] [log] [blame]
From c9120f0c15f901f507c0c626b7225f4e93fca700 Mon Sep 17 00:00:00 2001
From: Qian Hu <Qian.Hu@mediatek.com>
Date: Tue, 24 Sep 2019 11:21:23 +0800
Subject: [PATCH 1/8] [[PATCH 1/9] hmi-controller: use output_w/h instead of
current_mode_w/h
make use of output->w/h instead of output->current_mode->w/h,
output->w/h have involve factor of transform and scale
Signed-off-by: Qian Hu <Qian.Hu@mediatek.com>
---
ivi-shell/hmi-controller.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/ivi-shell/hmi-controller.c b/ivi-shell/hmi-controller.c
index a0e49ba..c4f106d 100644
--- a/ivi-shell/hmi-controller.c
+++ b/ivi-shell/hmi-controller.c
@@ -804,8 +804,8 @@ hmi_controller_create(struct weston_compositor *ec)
base_layer = MEM_ALLOC(1 * sizeof(struct hmi_controller_layer));
base_layer->x = 0;
base_layer->y = 0;
- base_layer->width = output->current_mode->width;
- base_layer->height = output->current_mode->height;
+ base_layer->width = output->width;
+ base_layer->height = output->height;
base_layer->id_layer =
hmi_ctrl->hmi_setting->base_layer_id +
(i * hmi_ctrl->hmi_setting->base_layer_id_offset);
@@ -824,8 +824,8 @@ hmi_controller_create(struct weston_compositor *ec)
application_layer = MEM_ALLOC(1 * sizeof(struct hmi_controller_layer));
application_layer->x = 0;
application_layer->y = 0;
- application_layer->width = output->current_mode->width;
- application_layer->height = output->current_mode->height - panel_height;
+ application_layer->width = output->width;
+ application_layer->height = output->height - panel_height;
application_layer->id_layer =
hmi_ctrl->hmi_setting->application_layer_id +
(i * hmi_ctrl->hmi_setting->base_layer_id_offset);
@@ -841,9 +841,9 @@ hmi_controller_create(struct weston_compositor *ec)
hmi_ctrl->workspace_background_layer.x = 0;
hmi_ctrl->workspace_background_layer.y = 0;
hmi_ctrl->workspace_background_layer.width =
- output->current_mode->width;
+ output->width;
hmi_ctrl->workspace_background_layer.height =
- output->current_mode->height - panel_height;
+ output->height - panel_height;
hmi_ctrl->workspace_background_layer.id_layer =
hmi_ctrl->hmi_setting->workspace_background_layer_id;
--
2.6.4