| From 08f1aa62f0a5faa0dc8aaf082264b77d37f0610d Mon Sep 17 00:00:00 2001 |
| From: Qian Hu <Qian.Hu@mediatek.com> |
| Date: Wed, 25 Sep 2019 19:14:50 +0800 |
| Subject: [PATCH] add switch_config |
| |
| Signed-off-by: Qian Hu <Qian.Hu@mediatek.com> |
| --- |
| compositor/main.c | 7 +++++++ |
| 1 file changed, 7 insertions(+) |
| |
| diff --git a/compositor/main.c b/compositor/main.c |
| index 21c501c..64e4e30 100644 |
| --- a/compositor/main.c |
| +++ b/compositor/main.c |
| @@ -2499,6 +2499,13 @@ int main(int argc, char *argv[]) |
| goto out; |
| } |
| |
| + |
| + if (config_switch_global_create(wet.compositor) < 0) { |
| + weston_log("fatal: failed to config_switch_global_create\n"); |
| + goto out; |
| + } |
| + |
| + |
| weston_compositor_flush_heads_changed(wet.compositor); |
| if (wet.init_failed) |
| goto out; |
| -- |
| 2.6.4 |
| |