blob: 7ffdec1fa6bcfa6b41ea281d4ec98ad3cbe81c28 [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
#
# output every command that modifies files on the build system.
# export DH_VERBOSE = 1
PACKAGENAME=u-boot
DESTDIR=$(shell pwd)/debian/$(PACKAGENAME)
DESTDIR_MKIMAGE=$(DESTDIR)-mkimage
%:
dh $@
override_dh_auto_build:
make -j$(shell nproc) CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)- mt8516_coral_defconfig
make -j$(shell nproc) CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)- _all u-boot-initial-env
override_dh_auto_install:
install -d $(DESTDIR)/usr/share/u-boot
install -d $(DESTDIR_MKIMAGE)/usr/bin
install -p -m 755 u-boot.bin $(DESTDIR)/usr/share/u-boot/u-boot.bin
install -p -m 755 u-boot-initial-env $(DESTDIR)/usr/share/u-boot/u-boot-initial-env
install -p -m 755 tools/mkimage $(DESTDIR_MKIMAGE)/usr/bin/mkimage
override_dh_strip:
true