blob: 8b16a992a9968abff94d64f6f531f65edf141ac6 [file] [log] [blame]
#!/usr/bin/make -f
# -*- makefile -*-
#
# output every command that modifies files on the build system.
# export DH_VERBOSE = 1
PACKAGENAME=optee-os
DESTDIR=$(shell pwd)/debian/$(PACKAGENAME)
%:
dh $@
override_dh_auto_clean:
true
override_dh_auto_build:
make -j$(shell nproc) \
PLATFORM=mediatek-mt8516 \
CFG_ARM64_core=y \
CROSS_COMPILE_core=$(DEB_HOST_GNU_TYPE)- \
CROSS_COMPILE_ta_arm64=$(DEB_HOST_GNU_TYPE)- \
NOWERROR=1 \
LDFLAGS= \
CFG_TEE_TA_LOG_LEVEL=0 \
ta-targets=ta_arm64
override_dh_auto_install:
install -d $(DESTDIR)/usr/share/optee-os
install -p -m 755 out/arm-plat-mediatek/core/tee.bin $(DESTDIR)/usr/share/optee-os/tee.bin