blob: 208ab09f10f1f0af28af0dd2e0ee727e6361e836 [file] [log] [blame]
diff --git a/gst/gstallocator.c b/gst/gstallocator.c
index 367fc2a9..ee78caf1 100644
--- a/gst/gstallocator.c
+++ b/gst/gstallocator.c
@@ -591,6 +591,12 @@ _priv_gst_allocator_initialize (void)
GST_CAT_DEBUG (GST_CAT_MEMORY, "memory alignment: %" G_GSIZE_FORMAT,
gst_memory_alignment);
+ if (gst_memory_alignment < 127) {
+ gst_memory_alignment = 127;
+ }
+ GST_CAT_DEBUG (GST_CAT_MEMORY, "Adjusted memory alignment: %" G_GSIZE_FORMAT,
+ gst_memory_alignment);
+
_sysmem_allocator = g_object_new (gst_allocator_sysmem_get_type (), NULL);
gst_allocator_register (GST_ALLOCATOR_SYSMEM,