blob: 95b89c52e92ecfb38eeb59588fa43f439077a834 [file] [log] [blame]
From 251ce6860c63eecb636778e5d109e11650f0d220 Mon Sep 17 00:00:00 2001
From: Fabien Parent <fparent@baylibre.com>
Date: Wed, 26 Aug 2020 19:10:57 +0200
Subject: [PATCH 4/5] Add support for non-continuous MT21 format
In order to use non-continuous MT21 planes, we need to set correctly
its fourcc_nc.
Signed-off-by: Fabien Parent <fparent@baylibre.com>
---
sys/v4l2/gstv4l2object.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/sys/v4l2/gstv4l2object.c b/sys/v4l2/gstv4l2object.c
index 4b4b29a830fd..886372789536 100644
--- a/sys/v4l2/gstv4l2object.c
+++ b/sys/v4l2/gstv4l2object.c
@@ -1851,6 +1851,7 @@ gst_v4l2_object_get_caps_info (GstV4l2Object * v4l2object, GstCaps * caps,
break;
case GST_VIDEO_FORMAT_MT21:
fourcc = V4L2_PIX_FMT_MT21;
+ fourcc_nc = V4L2_PIX_FMT_MT21;
break;
default:
break;
--
2.28.0