blob: c88c14f9959130684e69d97acdc8a74d2eb2b01e [file] [log] [blame]
From 1a4da293d0d22015240c81e5b056ba322c1529ea Mon Sep 17 00:00:00 2001
From: Alexandre Bailon <abailon@baylibre.com>
Date: Tue, 22 Sep 2020 15:33:19 +0200
Subject: [PATCH] Workaround concurrency issue
There is a concurrency issue between rsvg plugin and it parent's
class: videofilter.
Because of this issue, the plugin crash because it tries to write
a read only buffer.
Until we find a proper way to prevent the concurrency, use this
workaround to avoid the segfault.
Signed-off-by: Alexandre Bailon <abailon@baylibre.com>
Change-Id: I14f1c2a857fb949f53220f583615f6faa8e9ca26
---
ext/rsvg/gstrsvgoverlay.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ext/rsvg/gstrsvgoverlay.c b/ext/rsvg/gstrsvgoverlay.c
index 5f661b9a..48384573 100644
--- a/ext/rsvg/gstrsvgoverlay.c
+++ b/ext/rsvg/gstrsvgoverlay.c
@@ -137,7 +137,7 @@ gst_rsvg_overlay_set_svg_data (GstRsvgOverlay * overlay, const gchar * data,
if (overlay->handle) {
g_object_unref (overlay->handle);
overlay->handle = NULL;
- gst_base_transform_set_passthrough (btrans, TRUE);
+// gst_base_transform_set_passthrough (btrans, TRUE);
}
/* data may be NULL */
--
2.25.1