New upstream development release
diff --git a/debian/build-deps b/debian/build-deps
index dc1bc33..7595581 100644
--- a/debian/build-deps
+++ b/debian/build-deps
@@ -10,7 +10,7 @@
 @GST_EXTRA_BUILD_DEPENDS@
 @GST_LIB_DEV_DEP@
 gstreamer@GST_ABI@-doc
-gstreamer@GST_ABI@-plugins-base (>= 1.3.2)
+gstreamer@GST_ABI@-plugins-base (>= 1.3.3)
 gstreamer@GST_ABI@-plugins-base-doc
 gtk-doc-tools (>= 1.12)
 ladspa-sdk
@@ -35,7 +35,7 @@
 libgme-dev
 libgnutls-dev (>= 2.11.3)
 libgsm1-dev
-libgstreamer-plugins-base@GST_ABI@-dev (>= 1.3.2)
+libgstreamer-plugins-base@GST_ABI@-dev (>= 1.3.3)
 libgtk2.0-dev (>= 2.14.0)
 libiptcdata0-dev (>= 1.0.2)
 libjasper-dev
diff --git a/debian/build-deps.in b/debian/build-deps.in
index 5b481de..e11fdab 100644
--- a/debian/build-deps.in
+++ b/debian/build-deps.in
@@ -1,6 +1,6 @@
 @GST_LIB_DEV_DEP@
 @GST_EXTRA_BUILD_DEPENDS@
-libgstreamer-plugins-base@GST_ABI@-dev (>= 1.3.2)
+libgstreamer-plugins-base@GST_ABI@-dev (>= 1.3.3)
 autotools-dev
 dh-autoreconf
 automake (>= 1.11)
@@ -29,7 +29,7 @@
 libexempi-dev
 libiptcdata0-dev (>= 1.0.2)
 libwildmidi-dev (>= 0.2.3)
-gstreamer@GST_ABI@-plugins-base (>= 1.3.2)
+gstreamer@GST_ABI@-plugins-base (>= 1.3.3)
 libofa0-dev (>= 0.9.3)
 libdvdnav-dev (>= 4.1.2) [!hurd-any]
 libssl-dev
diff --git a/debian/changelog b/debian/changelog
index 688f781..5cf6c6f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+gst-plugins-bad1.0 (1.3.3-1) experimental; urgency=medium
+
+  * New upstream development release:
+    + debian/rules,
+      debian/build-deps.in:
+      - Build-depend on GStreamer core and base >= 1.3.3.
+    + debian/gstreamer-plugins-bad.install,
+      debian/libgstreamer-plugins-bad*.install:
+      - Add new compositor plugin and new libraries.
+  * debian/rules:
+    + Run autopoint during autoreconf.
+
+ -- Sebastian Dröge <slomo@debian.org>  Sun, 22 Jun 2014 18:14:52 +0200
+
 gst-plugins-bad1.0 (1.3.2-1) experimental; urgency=medium
 
   * New upstream development release:
diff --git a/debian/control b/debian/control
index cfbbbe0..7aae776 100644
--- a/debian/control
+++ b/debian/control
@@ -20,9 +20,9 @@
                libusb-1.0-0-dev [linux-any],
                libbluetooth-dev (<< 5) [linux-any],
                libsbc-dev (>= 1.1) [linux-any],
-               libgstreamer1.0-dev (>= 1.3.2),
+               libgstreamer1.0-dev (>= 1.3.3),
                gstreamer1.0-doc,
-               gstreamer1.0-plugins-base (>= 1.3.2),
+               gstreamer1.0-plugins-base (>= 1.3.3),
                gstreamer1.0-plugins-base-doc,
                gtk-doc-tools (>= 1.12),
                ladspa-sdk,
@@ -47,7 +47,7 @@
                libgme-dev,
                libgnutls-dev (>= 2.11.3),
                libgsm1-dev,
-               libgstreamer-plugins-base1.0-dev (>= 1.3.2),
+               libgstreamer-plugins-base1.0-dev (>= 1.3.3),
                libgtk2.0-dev (>= 2.14.0),
                libiptcdata0-dev (>= 1.0.2),
                libjasper-dev,
diff --git a/debian/gstreamer-plugins-bad.install b/debian/gstreamer-plugins-bad.install
index 160150b..e433637 100644
--- a/debian/gstreamer-plugins-bad.install
+++ b/debian/gstreamer-plugins-bad.install
@@ -14,6 +14,7 @@
 debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstcamerabin2.so
 debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstchromaprint.so
 debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstcoloreffects.so
+debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstcompositor.so
 debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstcurl.so
 debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstdashdemux.so
 debian/tmp/usr/lib/*/gstreamer-@GST_ABI@/libgstdataurisrc.so
diff --git a/debian/libgstreamer-plugins-bad.install b/debian/libgstreamer-plugins-bad.install
index 9b59d5d..7e3ed87 100644
--- a/debian/libgstreamer-plugins-bad.install
+++ b/debian/libgstreamer-plugins-bad.install
@@ -1,4 +1,6 @@
 debian/tmp/usr/lib/*/libgstphotography-@GST_ABI@.so.*
+debian/tmp/usr/lib/*/libgstbadbase-@GST_ABI@.so.*
+debian/tmp/usr/lib/*/libgstbadvideo-@GST_ABI@.so.*
 debian/tmp/usr/lib/*/libgstbasecamerabinsrc-@GST_ABI@.so.*
 debian/tmp/usr/lib/*/libgstgl-@GST_ABI@.so.*
 debian/tmp/usr/lib/*/libgstinsertbin-@GST_ABI@.so.*
diff --git a/debian/rules b/debian/rules
index 42fad2e..a3e0ffa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,9 +9,6 @@
 
 DEB_DH_AUTORECONF_ARGS += --as-needed
 
-# make autoreconf not call autopoint since we ship a patch for po/Makefile.in.in
-export AUTOPOINT=true
-
 CFLAGS += -Wno-error
 CXXFLAGS += -Wno-error
 LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed
@@ -48,7 +45,7 @@
 gst_lib=libgstreamer$(gst_abi)-0
 gst_lib_dev=libgstreamer$(gst_abi)-dev
 # what gstreamer version is needed
-gst_lib_dev_dep=$(gst_lib_dev) (>= 1.3.2)
+gst_lib_dev_dep=$(gst_lib_dev) (>= 1.3.3)
 
 gst_pkgname=gstreamer$(gst_abi)
 gst_deb_abi=$(gst_abi)-0