blob: 5d38737509c66ac138b498b6bfa155a63a31ca78 [file] [log] [blame]
#!/bin/sh -e
version=4.9.51-aiy
image_path=/boot/vmlinuz-$version
if [ "$1" != configure ]; then
exit 0
fi
depmod $version
if [ -f /lib/modules/$version/.fresh-install ]; then
change=install
else
change=upgrade
fi
linux-update-symlinks $change $version $image_path
rm -f /lib/modules/$version/.fresh-install
if [ -d /etc/kernel/postinst.d ]; then
DEB_MAINT_PARAMS="$*" run-parts --report --exit-on-error --arg=$version \
--arg=$image_path /etc/kernel/postinst.d
fi
exit 0